分数 25
全屏浏览题目
作者 CHEN, Yue
单位 浙江大学
The "travelling salesman problem" asks the following question: "Given a list of cities and the distances between each pair of cities, what is the shortest possible route that visits each city and returns to the origin city?" It is an NP-hard problem in combinatorial optimization, important in operations research and theoretical computer science. (Quoted from "https://en.wikipedia.org/wiki/Travelling_salesman_problem".)
In this problem, you are supposed to find, from a given list of cycles, the one that is the closest to the solution of a travelling salesman problem.
Input Specification:
Each input file contains one test case. For each case, the first line contains 2 positive integers N (2<N≤200), the number of cities, and M, the number of edges in an undirected graph. Then M lines follow, each describes an edge in the format City1 City2 Dist
, where the cities are numbered from 1 to N and the distance Dist
is positive and is no more than 100. The next line gives a positive integer K which is the number of paths, followed by K lines of paths, each in the format:
n C1 C2 ... Cn
where n is the number of cities in the list, and Ci's are the cities on a path.
Output Specification:
For each path, print in a line Path X: TotalDist (Description)
where X
is the index (starting from 1) of that path, TotalDist
its total distance (if this distance does not exist, output NA
instead), and Description
is one of the following:
TS simple cycle
if it is a simple cycle that visits every city;TS cycle
if it is a cycle that visits every city, but not a simple cycle;Not a TS cycle
if it is NOT a cycle that visits every city.
Finally print in a line Shortest Dist(X) = TotalDist
where X
is the index of the cycle that is the closest to the solution of a travelling salesman problem, and TotalDist
is its total distance. It is guaranteed that such a solution is unique.
Sample Input:
6 10
6 2 1
3 4 1
1 5 1
2 5 1
3 1 8
4 1 6
1 6 1
6 3 1
1 2 1
4 5 1
7
7 5 1 4 3 6 2 5
7 6 1 3 4 5 2 6
6 5 1 4 3 6 2
9 6 2 1 6 3 4 5 2 6
4 1 2 5 1
7 6 1 2 5 4 3 1
7 6 3 2 5 4 1 6
Sample Output:
Path 1: 11 (TS simple cycle)
Path 2: 13 (TS simple cycle)
Path 3: 10 (Not a TS cycle)
Path 4: 8 (TS cycle)
Path 5: 3 (Not a TS cycle)
Path 6: 13 (Not a TS cycle)
Path 7: NA (Not a TS cycle)
Shortest Dist(4) = 8
代码长度限制
16 KB
时间限制
250 ms
内存限制
64 MB
#include<bits/stdc++.h>
using namespace std;
const int N=209,INF=0x3f3f3f3f;
int n,m;
int g[N][N];
int minid,mindist=INF;//记录最小的回路编号和距离
int main(){
cin>>n>>m;
memset(g,0x3f,sizeof g);//初始化距离为无穷大
for(int i=0;i<m;i++){
int a,b,d;
cin>>a>>b>>d;
g[a][b]=g[b][a]=d;
}
int k;
cin>>k;
for(int i=1;i<=k;i++){//k个路径
int num;
cin>>num;//路径的结点个数
vector<int>v;
for(int j=0;j<num;j++){
int node;
cin>>node;
v.push_back(node);//结点插入数组
}
int total=0,flag=1;//分别表示总距离和是否是访问过所有结点的环
bool st[N]={0};//用来记录访问过的结点
for(int j=1;j<num;j++){
int a=v[j-1],b=v[j];
st[a]=true,st[b]=true;
if(g[a][b]==INF){//若邻接结点没有边
total=-1;//距离置为-1
break;
}
else total+=g[a][b];
}
if(v[0]!=v[num-1])flag=0;//若起点和终点不等则不是环
for(int i=1;i<=n;i++)if(!st[i])flag=0;//若有访问所有节点flag置0
if(total==-1)printf("Path %d: NA (Not a TS cycle)\n",i);//若不连通
else{//若连通了
if(flag){//若是访问过所有结点的环
if(total<mindist)mindist=total,minid=i;//更新路径编号和距离
if(num==n+1)printf("Path %d: %d (TS simple cycle)\n",i,total);//结点数为n+1则是简单回路
else if(num>n+1)printf("Path %d: %d (TS cycle)\n",i,total);//大于n+1则不是简单回路
}
else printf("Path %d: %d (Not a TS cycle)\n",i,total);//若不是访问过所有结点的环
}
}
printf("Shortest Dist(%d) = %d\n",minid,mindist);//输出最小距离回路的编号和距离
return 0;
}