VLAN与access接口、hybrid接口实验

news/2024/4/25 0:16:24/

在这里插入图片描述

[r1]dhcp enable //开启DHC0功能P

[r1-GigabitEthernet0/0/0]int g 0/0/0.1
[r1-GigabitEthernet0/0/0.1]ip add 192.168.1.1 24
[r1-GigabitEthernet0/0/0.1]dhcp select interface //接口地址池
[r1-GigabitEthernet0/0/0.1]dhcp server dns-list 8.8.8.8
[r1-GigabitEthernet0/0/0.1]dot1q termination vid 2 //开启子接口处理802.1Q数据帧的能力
[r1-GigabitEthernet0/0/0.1]arp broadcast enable //开启伪广播

[r1-GigabitEthernet0/0/2]ip add 192.168.2.1 24
[r1-GigabitEthernet0/0/2]dhcp select interface
[r1-GigabitEthernet0/0/2]dhcp server dns-list 8.8.8.8

[sw1]vlan batch 2 to 6
[sw2]vlan batch 2 to 6
[sw3]vlan batch 2 to 6
[sw1-GigabitEthernet0/0/1]port hybrid tagged vlan 2
[sw1-GigabitEthernet0/0/1]port hybrid untagged vlan 3 to 6
[sw1-GigabitEthernet0/0/2]port hybrid tagged vlan 2 to 6
[sw1-GigabitEthernet0/0/3]port link-type access
[sw1-GigabitEthernet0/0/3]port link-type access
[sw1-GigabitEthernet0/0/3]port default vlan 2
[sw1-GigabitEthernet0/0/4]port hybrid untagged vlan 3
[sw1-GigabitEthernet0/0/4]port hybrid pvid vlan 3
[sw1-GigabitEthernet0/0/4]port hybrid untagged vlan 3 to 6

[sw2-GigabitEthernet0/0/1]port hybrid tagged vlan 2 to 6
[sw2-GigabitEthernet0/0/2]port hybrid tagged vlan 2 to 6
[sw2-GigabitEthernet0/0/3]port link-type access
[sw2-GigabitEthernet0/0/3]port default vlan 2
[sw2-GigabitEthernet0/0/4]port hybrid pvid vlan 4
[sw2-GigabitEthernet0/0/4]port hybrid untagged vlan 3 to 5

[sw3-GigabitEthernet0/0/1]port hybrid tagged vlan 2 to 6
[sw3-GigabitEthernet0/0/2]port hybrid pvid vlan 5
[sw3-GigabitEthernet0/0/2]port hybrid untagged vlan 3 to 5
[sw3-GigabitEthernet0/0/3]port hybrid pvid vlan 6
[sw3-GigabitEthernet0/0/3]port hybrid untagged vlan 3 6

因为PC2、4、5、6处于同一网段,PC1、3处于同一网段
因此不能给每个vlan设置一个子接口网关

且PC1、3处于同一个VLAN,所以可以用一个子接口统一管理

而PC2、4、5、6分别处于不同的VLAN不能使用同一个子接口(dot1q termination vid x),但使用多个子接口又违背了要处于同一个网段的要求
所以只能用路由器的物理接口g0/0/0进行管理并且在SW1的g0/0/1接口把VLAN 2 to 6设为不携带标签转发


http://www.ppmy.cn/news/48047.html

相关文章

网络安全-网站后台的寻找+网页JS文件信息收集

网络安全-网站后台的寻找网页JS文件信息收集 前言 一,我也是初学者记录的笔记 二,可能有错误的地方,请谨慎 三,欢迎各路大神指教 四,任何文章仅作为学习使用 五,学习网络安全知识请勿适用于违法行为 学习网…

【Unity】基于AVFoundation开发MacOS摄像头(一)

起因:unity的自带WebCamTexture在mac上使用导致崩溃或花屏 复现步骤: mac里要有多个摄像头实例(包括自带摄像头、虚拟摄像头、外接usb摄像头);启动自己的app;启动会议软件或其他任何一个可以切换摄像头的…

Window下编译PJSIP,不编译Media模块

Windows系统下使用VS2017进行编译PJSIP。 下载地址 PJSIP的地址:https://github.com/pjsip/pjproject 在线clone太慢的话,可以直接在这里下载比clone会快很多: https://github.com/pjsip/pjproject/releases 安装OpenSSL 直接安装已经编译…

Blender3.5 视图切换

目录 1. 数字小键盘切换视图1.1 正交顶视图1.2 正交前视图1.3 正交右视图1.4 透视图1.5 四格视图 2. 鼠标点击切换视图2.1 点击视图,根据需求选择对应视图2.2 点导航栏的坐标轴切换 3. 启用字母区数字键3.1 编辑——偏好设置——输入——勾选“模拟数字键” 1. 数字…

Downie 4 4.6.14 MAC上最新最好用的一款视频下载工具

Downie for Mac 简介 Downie是Mac下一个简单的下载管理器,可以让您快速将不同的视频网站上的视频下载并保存到电脑磁盘里然后使用您的默认媒体播放器观看它们。 Downie 4 下载 Downie 4 for Mac Downie 4 for Mac软件特点 支持许多站点 -当前支持1000多个不同的…

使用计算机视觉实战项目精通 OpenCV:1~5

原文:Mastering OpenCV with Practical Computer Vision Projects 协议:CC BY-NC-SA 4.0 译者:飞龙 本文来自【ApacheCN 计算机视觉 译文集】,采用译后编辑(MTPE)流程来尽可能提升效率。 当别人说你没有底线…

拿下模板进阶

模板进阶 1. 非类型模板参数 模板参数分类类型形参与非类型形参。 类型形参即:出现在模板参数列表中,跟在class或者typename之类的参数类型名称。 非类型形参,就是用一个常量作为类(函数)模板的一个参数,在类(函数)模板中可将…

Java并发工具合集JUC大爆发

1. CountDownLatch CountDownLatch是一个同步计数器,初始化的时候 传入需要计数的线程等待数,可以是需要等待执行完成的线程数,或者大于 ,一般称为发令枪。\ ​ countdownlatch 是一个同步类工具,不涉及锁定&#xff0…

TitanIDE 新版本来袭,全新“效能看板”上线

TitanIDE产品团队于4月17日晚发布了TitanV2.6.3版本,作为一次重要的版本迭代,新版本主要增加/优化了以下重大功能: 全新效能看板上线,研发进度一目了然;新增代码拷贝、下载权限管理功能;项目启动提速&…

ObjectMapper 对象的基本使用(三)

一.简介 Jackson ObjectMapper可以从字符串、流或文件解析JSON,并创建Java对象或对象图来表示已解析的JSON。将JSON解析为Java对象也称为从JSON反序列化Java对象 Jackson ObjectMapper也可以从Java对象创建JSON. 从Java对象生成JSON的过程也被称为序列化Java对象到…

Leetcode912.排序数组(三路划分)

文章目录 一、三路划分二、Leetcode912.排序数组 一、三路划分 为何还会有三路划分? 快速排序算法在某个数据大量重复时效率极低,在运行程序时会超出时间限制,为了解决数据大量重复的情况下,三路划分诞生了。三路划分是基于快速排…

如何进行帕累托分析

【面试题】有一张“学生成绩表”,包含3个字段:学号、课程、成绩。 问题:找出每门课程A类和B类的学生,判断标准是累计占比,0~60%的记为A类,60%~85%记为B类 【解题思路】 什么是二八定律? 二八定律…

Java接口自动化测试框架系列:提升测试效率的自动化测试框架

目录:导读 一、什么是自动化测试 二、自动化测试的缺点 三、自动化测试框架选型 原则 对比 四、框架构建 【自动化测试工程师学习路线】 一、什么是自动化测试 自动化测试是把以人为驱动的测试行为转化为机器执行的一种过程。 通常,在设计了测试…

5.java程序员必知必会类库之excel读写库

前言 Excel在数据处理中的重要性自不必说,我们经常会有需求,将数据库中的数据,做过一些处理后,导出一个Excel给运营人员分析。也有需求是将批量的商品数据等,批量录入到我们系统中。直观上可以理解为Excel是客户和系统…

前端学习:HTML JavaScript

目录 一、JavaScript 使HTML页面更具有动态性和交互性 浏览器中的 JavaScript 能做什么? 二、 HTML 三、HTML标签 ​编辑 四、JavaScript 的功能示例 1. JavaScript 能够更改内容: 2. JavaScript能够更改样式: 3.JavaScript能够更改属性…

【Ruby 2D】【unity learn】抬头显示血条

说起游戏开发,大家一般会觉得控制角色移动和制作血条哪个难呢? 或许都会觉得血条比较难吧。 是的,正是如此。 那么我们让我们来看看血条该怎么做吧 这是效果图 受伤后是这样的 首先是创建一张Canvas画布 这个画布会很大 相比之下我们的小…

Spring AOP: 多切面的顺序,性能及异常监控

目录标题 一、Sprig的AOP操作JDK动态代理CGLib动态代理基于xml开发Spring AOP基于注解开发Spring AOP 二、多切面的顺序基于注解的配置基于Ordered接口配置基于XML配置 三、性能及异常监控性能监控异常监控 四、工程目录及运行结果图 一、Sprig的AOP操作 JDK动态代理 //接口 …

【STL】map容器

1、map容 map中所有元素都是pair组成pair中第一个元素为key(键值),起到索引作用,第二个元素为value(实值)所有元素都会根据元素的键值自动 排序 map/multimap属于关联式容器,底层结构由二叉树…

8万字智慧旅游景区信息化建设方案word

本资料来源公开网络,仅供个人学习,请勿商用,如有侵权请联系删除。 1.1. 整体建设框架 XXXXXX智慧景区旅游建设对于全面整合景区旅游资源,提升景区旅游产业发展能级,进一步增强景区旅游业的核心竞争力具有十分重要的支…

《Vue3实战》 第五章 计算、监听属性

《Vue3实战》篇章整体栏目 ————————————————————————————— 【第一章】node.js/npm安装、配置 【第二章】创建项目和目录结构 【第三章】基础语法 【第四章】条件语句、循环语句 【第五章】计算、监听属性 【第六章】样式绑定和事件处理 【第七章】…